All Microsoft Azure Services have fully recovered and are operating as expected. We have validated system stability and are now resolving this incident.
Posted Oct 30, 2025 - 00:39 UTC
Update
Microsoft Azure is continuing to observe recovery across affected services. Our systems remain stable, and we're monitoring closely.
Posted Oct 29, 2025 - 23:05 UTC
Update
Services seems to be stabilized and are now operational. We will continue to monitor for stability.
Posted Oct 29, 2025 - 22:02 UTC
Update
The Azure team has deployed their "last known good" configuration, and we are seeing gradual recovery in service health. We will continue to monitoring the service health closely.
Posted Oct 29, 2025 - 20:53 UTC
Monitoring
Our products are currently impacted by a widespread outage from Microsoft Azure. The next update will be provided in 30 minutes, or as events warrant. For more info, you can consult Microsoft Azure status page https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 17:41 UTC
This incident affected: DEXIS IS 3x00 family (DEXIS IS Connect).